Cherokee County School District GA - Destiny Unavailable – Incident details
Report an issue
Get updates
Email
Microsoft Teams
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Destiny Unavailable
Resolved
Operational
Started 2 months ago
Lasted about 1 hour
Affected
Learning Applications
Major outage from 11:57 AM to 1:01 PM
Destiny
Major outage from 11:57 AM to 1:01 PM
Updates
Resolved
March 03, 2025 at 1:01 PM
Resolved
March 03, 2025 at 1:01 PM
This incident has been resolved.
Investigating
March 03, 2025 at 11:57 AM
Investigating
March 03, 2025 at 11:57 AM
We are currently investigating this incident.